Jumat, April 24, 2009

Trunking dan link aggregation cisco 3550 dengan Allied Telesyn Layer 2

Assalamu'alaikum Wr. Wb
Link aggregation merupakan mengumpulkan lebih dari 1 link menjadi 1 link virtual. Ini sering digunakan untuk melakukan "bundling" suatu interface baik di switch maupun ethernet untuk memperbesar kapasitas dari link atau interface tersebut. Protokol yang sering digunakan dalam hal ini adalah lacp (Link Aggregation Control Protocol)

Link aggreation dapat dilakukan pada ethernet sesuai dengan sistem operasi yang digunakan, misalkan kita ingin mengambungkan 2 NIC dengan kapasitas 100Mbps mejadi 200Mbps dengan melakukan agregasi terhadap interface tersebut kemudian dihubungkan ke suatu manageble switch yang support agregasi. Interface agregasi untuk Debian/Linux dapat dijumpai disini

Untuk cisco 3550 konfigurasi untuk melakukan agregasi dapat menggunakan perintah channel-group,
seperti contoh berikut,

interface FastEthernet0/44
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 222,338,400
switchport mode trunk
channel-group 5 mode desirable
end

interface FastEthernet0/45
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 222,338,400
switchport mode trunk
channel-group 5 mode desirable
end

Pada konfigurasi di atas terlihat bahwa fastethernet ke 44 dan 45 dijadikan satu dalam channel group 5. hasil dari port channel dapat dilihat dengan perintah :

sh interface port-channel 5
Port-channel5 is down, line protocol is down (notconnect)
Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Auto-duplex, Auto-speed, media type is 10/100BaseTX
input flow-control is off, output flow-control is unsupported

Dari 2 interface yang sudah dijadikan satu tersebut kemudian dihubungkan dengan manageable switch allied telesyn. Secara prinsip kondigurasi yang dilakukan adalah serupa,

interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan add 222
switchport trunk allowed vlan add 338
switchport trunk allowed vlan add 400

interface range ethernet e(1-2)
channel-group 1 mode auto
lacp timeout short

Semoga bermanfaat

Wassalamu'alaikum Wr. Wb

Tidak ada komentar: